Problem
Ich kann meine Sprachserver im Dashboard nicht sehen. Und im entsprechenden Language Server Log sehe ich immer wieder folgenden Eintrag.
2019/06/20 10:36:21.766 | [WARN ][connector] Unable to report status to core server at http://localhost:8031/internal
Umgebung
Ich habe unsere Acrolinx-Umgebung gemäß dem Handbuch von einer Version kleiner als 5.4 auf eine Version größer als 5.4 aktualisiert.
Lösung
Aktualisieren Sie Ihre ls-<NUMBER>.properties-Dateien, die sich in Ihrem Konfigurationsverzeichnis befinden.
So aktualisieren Sie Ihre ls-<NUMBER>.properties-Dateien:
- Fahren Sie Ihre Core-Plattform herunter.
-
Navigieren Sie zum entsprechenden Konfigurationsverzeichnis für Ihr Betriebssystem (siehe Infobox unten).
Bei einer Windows-Installation befinden sich hier die ls-<NUMBER>.properties-Dateien:
C:\ProgramData\Acrolinx\ServerConfiguration\server\bin
Auf einer UNIX-Installation befinden sie sich in:
<USER_HOME>/.config/Acrolinx/ServerConfiguration<VERSION_NUMBER>/server/bin
-
Identifizieren Sie die Properties-Dateien Ihres Sprachservers.
Bei einer Standardinstallation sollten Sie 2 *.properties (ls-01.properties, ls-02.properties) haben. Je nach Konfiguration haben Sie möglicherweise mehr davon. -
Bearbeiten Sie jede Datei, um sicherzustellen, dass die Port-Nummer des lokalen Hosts 8032 ist.
## core server endpoint address coreServerEndpointUrl=http://localhost:8032/internal
Wenn dies nicht hilft oder wenn Sie nach dem Upgrade auf V5.4 des Acrolinx Servers weitere Probleme haben, wenden Sie sich bitte an den Acrolinx Support.
Ursache
Zur Verbesserung der Sicherheit verwendet der Hauptserver nun den Port 8032 für die Kommunikation und nicht länger den Port 8031.