Issue
Integrations no longer connect to Acrolinx or check. Depending on the integration, you get a different error message.
Something went wrong but we couldn't identify the cause 2019-07-12 15:27:05,848 | [INFO] ErrorDialog: Displaying error dialog Traceback (most recent call last): File ":/controller/maincontroller.py", line 135, in openSettings File ":/controller/maincontroller.py", line 676, in settingsTriggered File ":/application.py", line 485, in setCurrentServerSettings File ":/application.py", line 501, in updateCurrentServerCapabilities File ":/acrolinx2/server.py", line 511, in queryLanguages File ":/acrolinx2/server.py", line 106, in get File ":/acrolinx2/server.py", line 244, in __handleResponse File "/Applications/Acrolinx Content Analyzer.app/Contents/MacOS/site-packages/requests/models.py", line 939, in raise_for_status raise HTTPError(http_error_msg, response=self) HTTPError: 404 Client Error: Not Found for url: https://test-latest-ssl.acrolinx.com:443/languages
Affected Integrations
Classic Content Analyzer
Classic Word
The server couldn’t complete the check. The specified module could not be found. C:\Program Files (x86)\Acrolinx\PlugIns\acroWordPlugIn\AcssSoapAlpha.dll
javax.ws.rs.NotFoundException, HTTP 404 Not Found URL: /iq/services/v6/rest/checking/requests
Classic Oxygen
Connection to the server failed.
Scroll Acrolinx Connector for Confluence
Environment
After upgrading to Platform version 2019.07.1, integrations stop working.
Product |
Version |
---|---|
Platform | 2019.07.1 |
Classic Integrations |
Version |
---|---|
FrameMaker | 4.1-4.7 |
Content Analyzer | 1.0-1.3.2 |
Oxygen | 3.5 |
Word | 4.0-4.7 |
Command Line Checker | 2.7-3.6 |
ALIA (Acrolinx Linguistic Integration for Atom) | |
GitHub |
1.0-1.6 |
Partner Integrations |
Version |
---|---|
Cognitran Blaise | |
Astoria | |
Scroll Acrolinx Connector for Confluence (Java SDK) | |
SDL Passolo | |
Noxum Publishing Studio |
Cause
In Acrolinx Core Platform 2019.07.01, the Classic API is switched off by default.
Solution
Update to a Sidebar Integration that uses the Platform API.
Workaround
If you aren’t able to update to an integration that uses the Platform API, contact Acrolinx Support.