Applies To
Product |
Version |
---|---|
Acrolinx Core Platform |
2022.06* |
Acrolinx Operator | before 1.2.16+2021.12.1 |
Issue
Installing a new standard stack release isn’t possible because the old operators haven’t been uninstalled or deleted.
Cause
The problem will likely occur if the customer has ever installed an operator version older than 1.2.16+2021.12.1.
Solution
Uninstalling the Acrolinx Core Platform as described in our documentation prevents the issue.
Normal Standard Stack installs have all configuration and other persisted files stored in the mounted overlay directory, no data is lost. Databases should also be running outside of K3s, and therefore not be lost.
Workaround
If uninstalling the platform isn’t possible, or if there are already older operators running, a cleanup is needed.
Older operators can be removed with the following command:
kubectl delete deployment.apps/acrolinx-operator.v1.1.6 -n acrolinx-system
This will need to be done for all old operators versions.
The following command will show everything running in the cluster:
kubectl get all -A