Issue
Opening a link to Scorecard results in HTTP Error 403 message. You can't open a Scorecard or Term Discovery Report from an integration that uses a proxy.
Environment
Product |
Version |
---|---|
Acrolinx Core Platform Confluence Scroll Acrolinx Connector AEM (Adobe Experience Manager) Oxygen XML Web Author Drupal WordPress Any partner-built or customer-built Sidebar or automated check integration using SSO |
2019.09, 2019.10, and all future updates 3.13.2.1906181020 1.4, 1.5.x, 1.6 1.1, 1.2 1.0, 1.0.1 1.2, 1.3, 1.4
|
SSO configuration enabled:
Acrolinx Platform configurations:
features.enableLegacyCheckingApi = true
singleSignOn.method=header
Cause
Changes to the Core Platform 2019.09 introduced redirects of URLs to Scorecards and other reports that can be opened in a browser.
Integration proxies try to follow redirects automatically, which fails because of wrong target.
Solution
We're working on fixing the proxy code by disabling automatic redirect handling. Once that's done, we'll update all Acrolinx standard integrations to use the new proxy code. In addition, we'll work with our partners and customers to update their custom integrations that use proxies.
Workaround (Optional)
Scorecards generated by Acrolinx Core Platform versions 2019.08 and earlier open in a browser as expected. If you're considering updating your platform, wait until the integrations are updated.
If feasible, for the integration you use, you can temporarily disable SSO (single sign-on) so you can open the Scorecards directly.