Issue
The Content Analyzer ignores all the files that I try to check.
Applies To
Software | Version |
---|---|
Acrolinx Content Analyzer |
1.2, 1.3 |
Core Platform |
5.2 or later |
Cause
As of the version 1.2 release, it isn’t possible for Content Analyzer users to enter custom user information while signing in to Acrolinx. We’ll add this functionality in a future release.
If your Acrolinx administrator has activated custom user information, set the fields as mandatory, and your user profile is incomplete, then all Content Analyzer checks will fail.
You won’t see any explanation in the user interface or any error message. The Content Analyzer log file displays a message as follows:
2017-01-31 16:46:56 [AcrolinxRestApi] ERROR: <<< 403 Client error: { "message": "Check whether the user admin (admin) has completely filled out all additional user information.", "errors": { "userMetadataEditUrl": "http://localhost:8031/custom-data.html?userId\u003dadmin\u0026userToken\u003dkRliTiAVGr1jIshbYmXEAxUxLPREsmgzlk1HypLkUGQlzbVAy2EVorZmXSYSl3gNjYLfRrc9nx5jKELdeqeZOsgq6kQTmHd5UX7MR-4sXDQ8Ls6LEOLGk1YVqJ_Ovkev72ywIJ6cxQjP8x21HTK2Mw%3D%3D", "exception_type": "com.acrolinx.services.faults.UserMetadataIncompleteFault", "exception_message": "Check whether the user admin (admin) has completely filled out all additional user information." } }
Workaround
- If Content Analyzer users also have access to a Sidebar or Classic Integration, then you can first run a check in the authoring tool integration. Before checking, you’ll be prompted to complete your user profile. After that, you can then use the Content Analyzer and get results.
- Your Acrolinx administrator can set the additional user fields to optional instead of mandatory. Then the Content Analyzer will check content even if a user profile is incomplete
- (Requires the 5.2 server) Acrolinx administrators, or anyone with sufficient user privileges, can sign in to the Dashboard and fill out the custom user information on the Users page.