Issue
Batch Check
1. In Salesforce Knowledge, go to Knowledge→Draft Articles.
2. Select 1 or more articles by clicking the check box in the first column.
3. In the upper right, click the down arrow and click Check with Acrolinx from the dropdown.
→ Batch check starts but produces an error.
On the Acrolinx Batch Checks tab, the Acrolinx Score column and Status field in the right-hand panel show the following error message:Acrolinx Token request failed
On the Logs tab, the Message column shows the same error message:
Acrolinx Token request failed
Automated Check
A user inititates an automated check when they create a new article or save an existing article. The automated check happens in the background so you initially don't see any error message. But when you open the Logs tab, you'll see a log entry for the failed automated check.
The message field shows the error message:
Acrolinx Token request failed
The Source field shows:
EditWithAcrolinxVfCtrl.getSidebarConnectionDetails
The Detail field shows:
{"StackTrace":"(AcrolinxApp)","LineNumber":20}
Environment
Product |
Version |
---|---|
Acrolinx Platform | All |
Acrolinx Salesforce Knowledge | 3.1 or later |
Cause
If an Acrolinx administrator enabled custom user or custom document information and set the field Input Type to Required, then the automated and batch checks will fail. This will occur for users who haven't yet filled out their custom information. When a user initiates an automated or batch check, Acrolinx tries to authenticate the user who is currently signed in to Salesforce. The check fails because the Acrolinx Platform returns an error message due to the missing custom information.
When you use the Sidebar for the first time, Acrolinx prompts users to fill out any custom information. However, if you don't use the Sidebar and only use automated and batch checks, Acrolinx does not prompt you.
Resolution
Change the input type from Required
to Optional
Changing the input type is the quickest way to make sure Acrolinx works for both the Test SSO Connection and automated checks in Acrolinx for Salesforce Knowledge.
- In the Acrolinx Dashboard, go to Analytics→Administration→Custom Fields.
- Look on both the USERS and DOCUMENTS tabs to see if the input type is set to Required for any custom field.