Environment
Product |
Version |
---|---|
Acrolinx Application |
2023.03 and earlier |
Note: This was fixed by switching to a better Database locking mechanism that avoids these situations in Acrolinx Application 2023.04.
Issue
When accessing the Targets page in the Dashboard, the error message "Oops! That didn't work. It looks like something went wrong." appears.
Acrolinx checks are also unable to be completed and return the error "Connecting to server...Currently, there are no Targets available. Try again in a minute. If this keeps happening, contact your administrator to make sure you're correctly set up."
Cause
The acrolinx-targets-service is unable to start which makes Targets unavailable due to a Database change lock issue.
Solution
Steps required to resolve the issue.
-
Follow the steps in Manage the Server Logs and open the file "target-server-log.txt".
-
Check to see if acrolinx-targets-service gets stuck at the following message:
{"level":"INFO","thread":"main","logger":"com.zaxxer.hikari.HikariDataSource","message":"HikariPool-1 - Start completed.","context":"default"}
-
Scale down the targets deployment:
kubectl -n acrolinx scale deploy/acrolinx-target-service --replicas=0
-
Assuming an Oracle database is being used in the Targets database, run:
UPDATE DATABASECHANGELOGLOCK SET LOCKED=0;
-
Scale up the targets deployment:
kubectl -n acrolinx scale deploy/acrolinx-target-service --replicas=1
- Verify that the Targets page in the Dashboard is able to load correctly and Acrolinx checks are successful.