Environment
Product |
Version |
---|---|
Content Cube |
2023.03 and higher |
This issue pertains to any instance of Content Cube that was initially configured prior to the 2023.03 release.
Issue
While configuring Content Cube, you may experience an issue where the Acrolinx API token reports the following error message:
"Error while trying to validate Acrolinx API token: Insufficient privileges"
Cause
The cause of this error is the result of a misconfiguration of the "contentcube" user or its associated roles within the Acrolinx Platform. The "contentcube" user and roles required manual creation prior to the release of 2023.03.
Solution
To migrate to the new "auto-gen" method of creating the user/role, please see the Auto-Gen Acrolinx API Token For Content Cube Confluence Page. Ensure that the "contentcube" user has been created and assigned to the "Content Cube System" role, and that the role has the appropriate permissions as documented on the Confluence page.