Applies To
Software | Version |
---|---|
Acrolinx Server | Version 4.0 and later |
Symptoms
After you upgrade Acrolinx, the predefined roles that were introduced in the newer Acrolinx version are not added to your installation.
Causes
This issue might occur if you upgrade from an Acrolinx Server version 3.1 and lower to an Acrolinx Server version 3.2 or later. In Acrolinx Server version 3.2, we introduced a new license database format. This database replaced the previous license (ALD), user (AUD), and roles (ARD) database files. However, during the migration of these files, Acrolinx does not add new roles to the existing roles from the roles database.
Resolving the Problem
If you require predefined roles that were added with a particular Acrolinx version, and if these roles were not added during the upgrade, you must add the roles manually .